EzPortal - Portal Software for Forums

EzPortal - Made to Fit Your SMF Forum - Glad You Found Us!
+- +-

UserBox

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

+- Recent Posts

Re: Recent Topic Ezblock randomly showing "New" message indicator by EzPortal
January 14, 2020, 10:17:10 pm

Re: Recent Topic Ezblock randomly showing "New" message indicator by Paul_123
January 14, 2020, 09:31:26 pm

Re: Recent Topic Ezblock randomly showing "New" message indicator by EzPortal
January 14, 2020, 09:44:10 am

Re: Recent Topic Ezblock randomly showing "New" message indicator by EzPortal
January 14, 2020, 09:03:57 am

Re: Recent Topic Ezblock randomly showing "New" message indicator by Paul_123
January 13, 2020, 09:47:44 pm

Re: Recent Topic Ezblock randomly showing "New" message indicator by EzPortal
January 13, 2020, 04:55:05 pm

Re: Recent Topic Ezblock randomly showing "New" message indicator by Paul_123
January 13, 2020, 04:53:04 pm

Re: Recent Topic Ezblock randomly showing "New" message indicator by EzPortal
January 13, 2020, 01:53:35 pm

+- HTML Menu


Sample HTML Block Usage - You May Custom Code it, as needed!

Author Topic: Forum link doesn't stay highlighted if URL isn't index.php?action=forum  (Read 9130 times)

0 Members and 1 Guest are viewing this topic.

Offline n1k

  • Newbie
  • *
  • Posts: 5
  • Karma: 0
the Forum link in the menu bar doesn't stay highlighted if the URL isn't index.php?action=forum

the following URLs are part of the forum but the Home link becomes highlighted when they are used:

index.php?board=6.0
index.php?topic=50.0

try it on this site as an example:

http://www.ezportal.com/index.php?action=forum highlights the Forum link.
http://www.ezportal.com/support/ highlights the Home link even though it's part of the forum.
http://www.ezportal.com/support/adding-picture-or-videos/ this post highlights the Home link even though it's part of the forum.

how do i keep the Forum link highlighted when browsing index.php?board=6.0 and index.php?topic=50.0 ?

Offline EzPortal

  • Administrator
  • *****
  • Posts: 1221
  • Karma: 66
Re: Forum link doesn't stay highlighted if URL isn't index.php?action=forum
« Reply #1 on: October 01, 2012, 01:00:23 pm »
You would need to add a check to the hightlight code if board or topic id are present in the url then do the hightlight.
Like ezPortal? Support me at https://www.patreon.com/vbgamer45/

 

Related Topics

  Subject / Started by Replies Last post
0 Replies
3173 Views
Last post January 21, 2009, 04:22:45 am
by chinaren
2 Replies
4780 Views
Last post February 13, 2009, 09:37:08 am
by Drum4urlife
2 Replies
4827 Views
Last post July 30, 2010, 11:03:46 pm
by North East FL 4x4
6 Replies
9238 Views
Last post October 26, 2015, 09:52:25 am
by EzPortal
2 Replies
2080 Views
Last post January 14, 2019, 01:06:10 am
by Mont

+-SMF Gallery

Quick Menu



Members Online

12 Guests, 0 Users
Powered by EzPortal