EzPortal - Portal Software for Forums

EzPortal - Made to Fit Your SMF Forum - Glad You Found Us!
+- +-

UserBox

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

+- Recent Posts

Re: Converting to HTTPS by EzPortal
September 24, 2017, 07:11:26 pm

Converting to HTTPS by Padisha
September 24, 2017, 12:22:45 pm

Re: Mobile Only Blocks by EzPortal
September 23, 2017, 03:15:10 pm

Re: Mobile Only Blocks by morenos
September 23, 2017, 12:04:30 pm

Re: Members online block not displaying. by EzPortal
September 19, 2017, 12:02:55 pm

Re: Members online block not displaying. by Kocsis
September 19, 2017, 12:29:13 am

Re: EZPoll block by Julian
August 17, 2017, 03:43:31 am

Re: EZPoll block by EzPortal
August 16, 2017, 12:37:26 pm

+- HTML Menu


Sample HTML Block Usage - You May Custom Code it, as needed!

Author Topic: EZPortal Beta 3.1  (Read 20201 times)

0 Members and 1 Guest are viewing this topic.

Offline Kindred

  • Newbie
  • *
  • Posts: 12
  • Karma: 2
EZPortal Beta 3.1
« on: September 19, 2015, 05:26:16 am »
http://www.askawitchcommunity.org/index.php

this is a curve based theme....  with the responsive mod applied...   

unfortunately, the CSS does not appear to play nicely....

Offline EzPortal

  • Administrator
  • *****
  • Posts: 1159
  • Karma: 63
Re: EZPortal Beta 3.1
« Reply #1 on: September 19, 2015, 08:10:30 am »
Kindred trying copying the ezportal.css file from the themes/default/css folder to
http://www.askawitchcommunity.org/Themes/Curve_Minimal_Multicolor_2/css/

Looks like it is looking for it there.

Offline EzPortal

  • Administrator
  • *****
  • Posts: 1159
  • Karma: 63
Re: EZPortal Beta 3.1
« Reply #2 on: September 19, 2015, 08:19:19 am »

Offline Kindred

  • Newbie
  • *
  • Posts: 12
  • Karma: 2
Re: EZPortal Beta 3.1
« Reply #3 on: September 19, 2015, 09:23:11 am »
Can I just apply the update OVER the old one or do I have to do the uninstall/reinstall?

Offline EzPortal

  • Administrator
  • *****
  • Posts: 1159
  • Karma: 63
Re: EZPortal Beta 3.1
« Reply #4 on: September 19, 2015, 09:24:54 am »
Try but I think I have the same package-info id so you may need to uninstall.

Offline Kindred

  • Newbie
  • *
  • Posts: 12
  • Karma: 2
Re: EZPortal Beta 3.1
« Reply #5 on: September 19, 2015, 09:33:38 am »
never mind -- just did the uninstall/reinstall.

That looks better now. :)

Offline Kindred

  • Newbie
  • *
  • Posts: 12
  • Karma: 2
Re: EZPortal Beta 3.1
« Reply #6 on: September 19, 2015, 09:37:56 am »
I think, however, that the "newsest member" pre-defined block has some screwy content....   if messes up the block above it when it is present.

hmmm.... same thing happens with the top poster's block...

perhaps the issue is with the "PHP block" above it... but the code in there looks clean to me.

Offline Kindred

  • Newbie
  • *
  • Posts: 12
  • Karma: 2
Re: EZPortal Beta 3.1
« Reply #7 on: September 19, 2015, 09:41:38 am »
ah.... another problem.

it is not respecting the "right column" settings.

on both http://www.askawitchcommunity.org/index.php?action=forum and http://www.40konline.com/index.php?action=forum
the right column does not hide on the forum display, like it used to...

Offline Kindred

  • Newbie
  • *
  • Posts: 12
  • Karma: 2
Re: EZPortal Beta 3.1
« Reply #8 on: September 19, 2015, 09:45:55 am »
hmmm again... the right column itself is not being displayed -- but the center column is FIXED at 70% - so it does not expand to fill in the space, if the column is hidden

Offline Kindred

  • Newbie
  • *
  • Posts: 12
  • Karma: 2
Re: EZPortal Beta 3.1
« Reply #9 on: September 20, 2015, 01:01:05 pm »
ummm.... Wow.

There are a lot of things wrong with this implementation.

first and foremost -- the implementation assumes that all three columns are always present
second -- because of first, it FORCES the columns to be 15%, 70% and 15%  -- regardless of what the settings are in EZPortal admin and regardless of what content is in there.

third -- removing the 70% from the center content does not work -- one would assume that with 15% defined to the left and 15% defined to the right - removing the FORCED size form the center column would just take whatever remaining space was available. Unfortunately this is not so -- without SEPCIFICALLY 15/70/15, the content drops below the left column -- and looks like complete crap.

Basically - the work done to make this responsive is making it look worse than the original table (which actually did handle the decreasing screen size correctly) -- and seems to ignore the settings of the clocks and columns

Offline EzPortal

  • Administrator
  • *****
  • Posts: 1159
  • Karma: 63
Re: EZPortal Beta 3.1
« Reply #10 on: September 21, 2015, 10:26:51 am »
We will review these posts and work our developers.

Offline Antes

  • Global Moderator
  • *****
  • Posts: 23
  • Karma: 0
Re: EZPortal Beta 3.1
« Reply #11 on: September 21, 2015, 11:42:38 am »
ummm.... Wow.

There are a lot of things wrong with this implementation.

first and foremost -- the implementation assumes that all three columns are always present
second -- because of first, it FORCES the columns to be 15%, 70% and 15%  -- regardless of what the settings are in EZPortal admin and regardless of what content is in there.

third -- removing the 70% from the center content does not work -- one would assume that with 15% defined to the left and 15% defined to the right - removing the FORCED size form the center column would just take whatever remaining space was available. Unfortunately this is not so -- without SEPCIFICALLY 15/70/15, the content drops below the left column -- and looks like complete crap.

Basically - the work done to make this responsive is making it look worse than the original table (which actually did handle the decreasing screen size correctly) -- and seems to ignore the settings of the clocks and columns

I think I need more details on this "a lot of things", while you only said only one thing and w/o asking the reason to do it. We did it for a reason to have a base ground (its ignoring because modern browsers are ignoring the width, it should be style="width: <stuff>;". As you can see the feature of giving width to a column is not removed.

Since I don't have any permission to attach files here (dunno why).

http://www.mmobrowser.com/smf2mobile/ezPortal_qfix.zip

Offline EzPortal

  • Administrator
  • *****
  • Posts: 1159
  • Karma: 63
Re: EZPortal Beta 3.1
« Reply #12 on: September 21, 2015, 12:14:07 pm »
Fixed file post permissions.

Offline Maxx

  • VN Vet E4
  • Hero Member
  • *****
  • Posts: 560
  • Karma: 8
  • Gender: Male
  • Web Designer
    • SurfaceThemes - Web Design Ideas Classic Rock
Re: EZPortal Beta 3.1
« Reply #13 on: September 21, 2015, 09:43:37 pm »
As far as the panels go I have my center set to 100% and the left right at approx 18%, once the left and right are close the center goes to 100% of the content: I have it set up it the smf 2.l Beta if you'll like ti check out. sorry been busy doing themes and studying code other CMS stuff, ;last time I checked on my windows phone, the panels close, but  have not check with this update.

http://www.buildandtell.com/index.php?action=forum

I will check again in morning on the smf 2.0.11.
We know there are issues but, in some ways more advance thinking on today's trends. and improvement are being done on a regular basses. :)

Glad to see some concerns and feed back though :)

regards,
Maxx

Offline Maxx

  • VN Vet E4
  • Hero Member
  • *****
  • Posts: 560
  • Karma: 8
  • Gender: Male
  • Web Designer
    • SurfaceThemes - Web Design Ideas Classic Rock
Re: EZPortal Beta 3.1
« Reply #14 on: September 22, 2015, 08:31:31 am »
Ok, just and FYI for Ez!

On the Columns or panels, toying with though on the SMF 2.0.11, I found that the only one that does play nice is the right side.

Setting the Center at 80% to 100% works fine setting the right at 16% - 19 % and the center will go to 100 percent while closing the left and right sides.

The Left side shrinks at any width setting, when all are open or on!
although there may be other issues with the center, it can be set at 100% if you like and left will work fine at your 18+ percent setting!

http://smf.surfacethemes.com/index.php

Not a fix :) just a test result and a somewhat of a temp work around !

regards,
Maxx

 

Related Topics

  Subject / Started by Replies Last post
0 Replies
12766 Views
Last post October 12, 2008, 07:30:25 pm
by EzPortal
2 Replies
10364 Views
Last post December 26, 2014, 05:06:34 pm
by Maxx
2 Replies
10591 Views
Last post September 06, 2015, 07:42:00 am
by Teru Mikami
8 Replies
16365 Views
Last post September 30, 2015, 03:35:03 am
by Vincent Volmer
2 Replies
3299 Views
Last post March 12, 2016, 09:29:48 am
by Kindred

+-SMF Gallery

Quick Menu








Members Online

21 Guests, 0 Users
Powered by EzPortal