EzPortal - Portal Software for Forums

EzPortal - Made to Fit Your SMF Forum - Glad You Found Us!
+- +-

UserBox

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

+- Recent Posts

Minor Update for SMF 2.1.x by EzPortal
October 18, 2020, 09:33:09 am

Re: EzPortal unable to be seen by user with primary custom usergroup by EzPortal
October 12, 2020, 07:55:08 am

EzPortal unable to be seen by user with primary custom usergroup by radi27
October 11, 2020, 04:46:32 pm

Show Likes mod by NickT
July 10, 2020, 12:09:44 pm

Re: ezPortal inbuilt module downloaders not working. by EzPortal
March 26, 2020, 08:19:48 am

Re: ezPortal inbuilt module downloaders not working. by Valdivia
March 26, 2020, 08:16:33 am

Re: ezPortal inbuilt module downloaders not working. by EzPortal
February 12, 2020, 10:01:42 pm

Re: ezPortal inbuilt module downloaders not working. by usalabs
February 12, 2020, 05:59:54 pm

+- HTML Menu


Sample HTML Block Usage - You May Custom Code it, as needed!

Author Topic: Issue with custom ezBlock  (Read 4156 times)

0 Members and 1 Guest are viewing this topic.

Offline fobnicat

  • Newbie
  • *
  • Posts: 8
  • Karma: 0
Issue with custom ezBlock
« on: September 30, 2014, 11:20:13 pm »
Hi all,

I apologize for being quite the nuisance with so many simple questions, but I appreciate all of the help.

I have written a very basic block to get started.  This block will allow my moderators to enter in basic information to display a monthly winner.

I have searched over for any syntax errors, but I cant find any, yet I am still getting "ezBlock unable to run PHP syntax error!"

Any help?

Code: [Select]
<blockdata><![CDATA[echo '<h1>' . $parameter1 . "'s ROTM is sponsored by " . $parameter2 . '</h1>'

echo '<b>Congratulations ' . $parameter3 .' ' . $parameter4 . " for being this month's winner!</b>"
echo . $parameter3 . ' will be receiving ' . $parameter5 . ' from ' . $parameter2 . '!'

echo 'Now check out ' . $parameter3 . "'s winning " . $parameter6 . ':

echo '<img src="/images/rotm/' . $parameter7 . '">'
]]></blockdata>

I only posted the block data due to there being no issues entering the form data leading me to believe the parameters section is clean.

Offline EzPortal

  • Administrator
  • *****
  • Posts: 1227
  • Karma: 66
Re: Issue with custom ezBlock
« Reply #1 on: September 30, 2014, 11:22:57 pm »
Updated code
Code: [Select]
<blockdata><![CDATA[echo '<h1>' . $parameter1 . "'s ROTM is sponsored by " . $parameter2 . '</h1>';

echo '<b>Congratulations ' . $parameter3 .' ' . $parameter4 . " for being this month's winner!</b>";
echo  $parameter3 . ' will be receiving ' . $parameter5 . ' from ' . $parameter2 . '!';

echo 'Now check out ' . $parameter3 . "'s winning " . $parameter6 . ': ';

echo '<img src="/images/rotm/' . $parameter7 . '">';
]]></blockdata>
Like ezPortal? Support me at https://www.patreon.com/vbgamer45/

Offline fobnicat

  • Newbie
  • *
  • Posts: 8
  • Karma: 0
Re: Issue with custom ezBlock
« Reply #2 on: September 30, 2014, 11:29:24 pm »
 :o I did it again  :-\

Thank you! ;D

 

Related Topics

  Subject / Started by Replies Last post
22 Replies
53022 Views
Last post April 23, 2015, 02:08:54 pm
by EzPortal
3 Replies
5926 Views
Last post May 18, 2009, 10:56:13 pm
by fisho
8 Replies
14828 Views
Last post July 01, 2010, 04:26:42 pm
by krice
2 Replies
4400 Views
Last post February 08, 2012, 09:52:43 pm
by wireplay
0 Replies
4320 Views
Last post June 27, 2013, 09:15:48 am
by saintblue

+-SMF Gallery

Quick Menu



Members Online

20 Guests, 0 Users
Powered by EzPortal