EzPortal - Portal Software for Forums

EzPortal - Made to Fit Your SMF Forum - Glad You Found Us!
+- +-

UserBox

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

+- Recent Posts

Re: How to add pictures on recent post ezportal front page by Botango23
June 30, 2018, 03:38:18 am

Re: How to add pictures on recent post ezportal front page by EzPortal
June 29, 2018, 06:21:42 pm

How to add pictures on recent post ezportal front page by Botango23
June 29, 2018, 04:47:11 pm

Re: Surface ol lite theme release Free! by Higby
June 29, 2018, 07:58:33 am

Re: ezBlock listed as installed by EzPortal
June 06, 2018, 11:18:36 am

Re: ezBlock listed as installed by MamaTea
June 06, 2018, 10:54:41 am

Re: ezBlock listed as installed by MamaTea
June 06, 2018, 10:38:48 am

ezBlock listed as installed by MamaTea
June 06, 2018, 10:31:32 am

+- HTML Menu


Sample HTML Block Usage - You May Custom Code it, as needed!

Author Topic: Issue with blockdata  (Read 3690 times)

0 Members and 1 Guest are viewing this topic.

Offline wireplay

  • Newbie
  • *
  • Posts: 8
  • Karma: 0
Issue with blockdata
« on: February 08, 2012, 09:46:40 pm »
Guys,

The blockdata tag is appearing on the screen with the other parameters. This is even happening in the sample.

I am trying to create a recent topics ezblock but with filtering by a board. It seems like this has been started in the code, to some extent.

Here is my current code:

<?xml version="1.0"?>
<!DOCTYPE block-info SYSTEM "http://www.ezportal.com/xml/block-info">
<block-info xmlns="http://www.ezportal.com/xml/block-info" xmlns:ezportal="http://www.ezportal.com/">
<id>TBL:RecentTopicsWithFilter</id>
<title>Recent Topics With Filter</title>
<version>1.1</version>
<blocktype>php</blocktype>
<forumversion>SMF 2.0.x</forumversion>
<author>TBL</author>
<website>http://www.trueblueliberty.com</website>
<editable>1</editable>
<can_cache>1</can_cache>
<parameter1>
   <type>int</type>
   <required>1</required>
   <title>Number of Topics to show</title>
   <order>1</order>
</parameter1>
<parameter2>
   <type>boardselect</type>
   <required>1</required>
   <title>Board to select from</title>
   <order>2</order>
</parameter2>
<blockdata><![CDATA[
function EzBlockTBLTop....
]]>
</blockdata>
</block-info>

I saw that it was alluded to in another post but will you support a recent topics by board soon?

Offline EzPortal

  • Administrator
  • *****
  • Posts: 1178
  • Karma: 63
Re: Issue with blockdata
« Reply #1 on: February 08, 2012, 09:52:21 pm »
I would change
<editable>1</editable>
To
<editable>0</editable>

That should stop the editable portion if you see all the block code.
Like ezPortal? Support me at https://www.patreon.com/vbgamer45/

Offline wireplay

  • Newbie
  • *
  • Posts: 8
  • Karma: 0
Re: Issue with blockdata
« Reply #2 on: February 08, 2012, 09:52:43 pm »
Wait, wait, wait. That was a STUPID question. Of course it will be in there for editing.

 

Related Topics

  Subject / Started by Replies Last post
1 Replies
3542 Views
Last post February 15, 2009, 08:16:13 pm
by EzPortal
1 Replies
4895 Views
Last post August 16, 2009, 09:14:09 am
by kinin
7 Replies
4407 Views
Last post August 12, 2010, 06:31:52 am
by EzPortal
0 Replies
3934 Views
Last post June 27, 2013, 09:15:48 am
by saintblue
2 Replies
3287 Views
Last post September 30, 2014, 11:29:24 pm
by fobnicat

+-SMF Gallery

Quick Menu








Members Online

22 Guests, 0 Users
Powered by EzPortal