EzPortal - Portal Software for Forums

EzPortal - Made to Fit Your SMF Forum - Glad You Found Us!
+- +-

UserBox

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

+- Recent Posts

Re: Blocks Help by Riggs1973
November 20, 2022, 12:59:30 pm

Re: Blocks Help by EzPortal
November 19, 2022, 10:22:00 am

Blocks Help by Riggs1973
November 19, 2022, 09:51:15 am

Re: Surface ol lite theme release Free! by Steffen K.
November 18, 2022, 03:57:24 am

Re: Surface ol lite theme release Free! by EzPortal
November 17, 2022, 12:49:08 pm

Re: Surface ol lite theme release Free! by Steffen K.
November 17, 2022, 12:14:17 pm

Re: Undefined index: href by EzPortal
October 04, 2022, 08:49:59 pm

Re: Undefined index: href by Shades
October 04, 2022, 08:28:41 pm

+- HTML Menu


Sample HTML Block Usage - You May Custom Code it, as needed!

Recent Topics ezBlock

Blocks Help by Riggs1973
November 20, 2022, 12:59:30 pm

Surface ol lite theme release Free! by Steffen K.
November 18, 2022, 03:57:24 am

Undefined index: href by EzPortal
October 04, 2022, 08:49:59 pm

SMF-ezportal_column_5.cache): failed to open stream: No such file or directory by EzPortal
June 04, 2022, 11:40:13 am

Arcade block error: failed to open stream: No such file or directory by Shades
May 20, 2022, 02:47:13 pm

ezPortal 5.5 by EzPortal
May 20, 2022, 09:59:30 am

Image/Attachment display issue by Shades
May 16, 2022, 02:28:35 pm

Can't delete custom actions by Shades
April 13, 2022, 12:53:28 pm

Newest Member ezblock by Shades
March 23, 2022, 12:48:32 pm

Random Download Block by Shades
March 22, 2022, 10:37:47 am

Author Topic: Undefined index  (Read 24293 times)

0 Members and 1 Guest are viewing this topic.

Offline Eddy Matthews

  • Jr. Member
  • **
  • Posts: 56
  • Karma: 1
  • Gender: Male
Undefined index
« on: December 07, 2009, 05:04:11 am »

Apply Filter: Only show the error messages of this URL
http://www.paddleducks.co.uk/smf/index.php?action=who
Apply Filter: Only show the errors with the same message
8: Undefined index: newwindow
Apply Filter: Only show the errors from this file
File: /home/xxxx/public_html/smf/Sources/Subs-EzPortalMain2.php
Line: 2970


Regards
Eddy

Offline chinaren

  • Jr. Member
  • **
  • Posts: 55
  • Karma: 4
  • www.TomeCity.com
    • Read Tired of Death for free!
Re: Undefined index
« Reply #1 on: February 22, 2010, 09:29:32 pm »
I'm going to leap onto Eddy's bandwagon here if I may.  

I'm also getting an UI error.  Lots of them actually.

It doesn't seem to be affecting the usability of the board/EZPortal, but it's a bit annoying.  The error in the error log goes something like:

Quote
http://(url)/index.php?action=gallery;sa=view;id=531    <-- This line is different each time.

8: Undefined index: downloads_text_downloads
File: /home/(url)/Sources/Subs-EzPortalMain.php
Line: 1507

Not sure when it started, but I think recently (may be wrong), about the same time I upgraded to the latest EZP.  However, about the same time I upgraded to SMF 1.1.11.  Also I may just not have noticed this before.  :-\

Any help greatly appreciated.


Offline EzPortal

  • Administrator
  • *****
  • Posts: 1293
  • Karma: 67
Re: Undefined index
« Reply #2 on: February 22, 2010, 11:46:41 pm »
Looks like a missing language file will take a look at that.
Like ezPortal? Support me at https://www.patreon.com/vbgamer45/

Offline chinaren

  • Jr. Member
  • **
  • Posts: 55
  • Karma: 4
  • www.TomeCity.com
    • Read Tired of Death for free!
Re: Undefined index
« Reply #3 on: February 23, 2010, 04:37:48 am »
Thanks! :)


Offline EzPortal

  • Administrator
  • *****
  • Posts: 1293
  • Karma: 67
Re: Undefined index
« Reply #4 on: February 24, 2010, 02:21:24 pm »
Hotfix add this to your downloads.english.php file or ezportal.english.php file
Code: [Select]
$txt['downloads_text_downloads'] = 'Downloads: ';
Like ezPortal? Support me at https://www.patreon.com/vbgamer45/

Offline chinaren

  • Jr. Member
  • **
  • Posts: 55
  • Karma: 4
  • www.TomeCity.com
    • Read Tired of Death for free!
Re: Undefined index
« Reply #5 on: February 25, 2010, 06:11:39 pm »
I think that's fixed it!  Thanks, I'll monitor and let you know.


Offline frost

  • Posts: 2
  • Karma: 0
Re: Undefined index
« Reply #6 on: April 05, 2010, 09:27:27 pm »
05 April 2010, 15:34:34
Type of error: Undefined
URL: http://www.thirdworldnetwork.org/forum/index.php?action=admin;area=ezpsettings;sa=settings
8: Undefined index: label
File: /thirdworldnetwork.org/forum/Themes/default/GenericMenu.template.php (generic_menu_sidebar_above sub template - eval?)
Line: 308

Fresh installs of both SMF and EZPortal.

So, let's look at the line in question:

Code: [Select]
<a class="firstlevel" href="', isset($tab['url']) ? $tab['url'] : $menu_context['base_url'] . ';area=' . $menu_context['current_area'] . ';sa=' . $sa, $menu_context['extra_parameters'], isset($tab['add_params']) ? $tab['add_params'] : '', '"><span class="firstlevel">', $tab['label'], '</span></a>

Offline royalduke

  • EzPortal Supporter
  • *****
  • Posts: 5
  • Karma: 0
Re: Undefined index
« Reply #7 on: April 06, 2010, 07:35:51 am »
hi everyone
i am currently working as a design manager
I am 32 and a father of 2. I am an expert on home improvement, check out my latest tips on how to seal your shower and bath

Spam? O.o
EzPortal's Unofficial Team Member O.o

C'mon people! If you want EzPortal to be great convince vbgamer to create a real team for this awesome project. Soon, we will take over the universe and destroy all the other SMF portals!

Offline frost

  • Posts: 2
  • Karma: 0
Re: Undefined index
« Reply #8 on: April 06, 2010, 12:45:15 pm »
05 April 2010, 15:34:34
Type of error: Undefined
URL: http://www.thirdworldnetwork.org/forum/index.php?action=admin;area=ezpsettings;sa=settings
8: Undefined index: label
File: /thirdworldnetwork.org/forum/Themes/default/GenericMenu.template.php (generic_menu_sidebar_above sub template - eval?)
Line: 308

Fresh installs of both SMF and EZPortal.

So, let's look at the line in question:

Code: [Select]
<a class="firstlevel" href="', isset($tab['url']) ? $tab['url'] : $menu_context['base_url'] . ';area=' . $menu_context['current_area'] . ';sa=' . $sa, $menu_context['extra_parameters'], isset($tab['add_params']) ? $tab['add_params'] : '', '"><span class="firstlevel">', $tab['label'], '</span></a>

Just want to make sure we stay on topic... anyone have a clue as to why this is the ONLY error on my site...?

 

Related Topics

  Subject / Started by Replies Last post
4 Replies
10341 Views
Last post November 15, 2009, 12:59:02 pm
by lumumba
1 Replies
10638 Views
Last post April 24, 2011, 03:12:48 pm
by EzPortal
5 Replies
4639 Views
Last post January 03, 2018, 01:14:01 pm
by EzPortal
2 Replies
3458 Views
Last post February 01, 2022, 12:26:03 pm
by Shades
8 Replies
2736 Views
Last post October 04, 2022, 08:49:59 pm
by EzPortal

+-SMF Gallery

Quick Menu


Powered by EzPortal